'Inteligenty' dom ze sterownikiem PLC

 Language:
Szukanie zaawansowane  

Aktualności:

Powrót do strony głównej: www.edom-plc.pl

Autor Wątek: Temperatura - DS18B20  (Przeczytany 11310 razy)

admin

  • Administrator
  • Sr. Member
  • *****
  • Wiadomości: 294
    • Zobacz profil
Odp: Temperatura - DS18B20
« Odpowiedź #15 dnia: Czerwiec 26, 2013, 10:40:40 pm »

Witam,

Skrócony opis wykorzystania biblioteki WagoLibHttp_02.lib do rozmowy z RPi jest w drugiej części http://www.edom-plc.pl/index.php?option=com_content&view=article&id=97.

W międzyczasie sporo dodałem, ale... na opisanie tego potrzeba czasu, a za chwile urlop :)

Pozdrawiam,
Zapisane

ziutol

  • Newbie
  • *
  • Wiadomości: 11
    • Zobacz profil
Odp: Temperatura - DS18B20
« Odpowiedź #16 dnia: Luty 17, 2016, 10:34:37 pm »

Witam  mam [problem z  biblioteką Wagolibhttp_02    korzystam z przykładu  wado  nr 2  i pojawia mi się  błąd

16#80001002: TCP-ERROR: Could not convert servers IP address into dotted
 format'

adres mam poprawnie wpisany  nie mam pojęcia  co może  być  przyczyną. Może  ktoś z was miał podobny problem . Będę wdzięczny za  każdą wskazówkę.
Zapisane

bboson

  • Newbie
  • *
  • Wiadomości: 1
    • Zobacz profil
Odp: Temperatura - DS18B20
« Odpowiedź #17 dnia: Marzec 23, 2016, 11:31:38 pm »

Robiąc internetowy termometr na Raspberry Pi musisz mieć świadomość, że błędy na pewno będą się pojawiać. Ja odkąd zainstalowałem swój termometr na Raspberry Pi za każdym razem mam styczność z jakimś błędem, który towarzyszy przy ujemnej temperaturze. Jeżeli jest na plus, to wszystko jest ok. Chyba jest to normalne, że przy ujemnej temperaturze, komputer nie może jej dokładnie ocenić. Ważne, że z precyzją pokazuje temperaturę dodatnią, tym bardziej rzadko kiedy jest ujemna.

kamiKAC

  • Jr. Member
  • **
  • Wiadomości: 66
    • Zobacz profil
Odp: Temperatura - DS18B20
« Odpowiedź #18 dnia: Kwiecień 27, 2016, 04:13:06 pm »

Przepraszam, że odgrzewam stare kotlety, ale czy przypadkiem problem z odczytem ujemnych temperatur nie wynika z zastosowania typu UINT zamiast INT przy przekazywaniu wartości? Miałem ten sam problem przy odczycie temperatur poprzez MODBUS.

Pozdrawiam
--
kamiKAC
Zapisane